Problem with search

Ask the community for help and support.
Post Reply
Piernas
Posts: 77
Joined: Thu Mar 11, 2021 2:16 am
Has thanked: 2 times
Been thanked: 5 times

Problem with search

Post by Piernas »

I've found an strange issue on a localhost setup (XAMPP/windows 10).

If I search for words that include non-latin characters like "ç", "ñ" or "ë" the search does not work. Looks like strtolower function is returning these characters as � character, so the search query is not returning anything.

That search works on an online setup so I presume it has something to do with the Xampp setup. It is fixed by using mb_strtolower instead strtolower in the search class.

Can someone confirm if that kind of search works on other localhost setup? Any idea why the strtolower function corrupts characters?
raiwa
PhoenixCart Developer
PhoenixCart Developer
Posts: 804
Joined: Sat Dec 21, 2019 8:08 am
Has thanked: 32 times
Been thanked: 75 times

Re: Problem with search

Post by raiwa »

confirmed for Phoenix 1.0.8.16 on local xampp PHP 8.0
Public Phoenix Change Log Cheat Set on Google Sheets
https://docs.google.com/spreadsheets/d/ ... sp=sharing

Need Help?viewtopic.php?f=10&t=27
User avatar
Kofod95
VIP Member
VIP Member
Posts: 326
Joined: Sat Feb 06, 2021 7:38 pm
Has thanked: 50 times
Been thanked: 82 times

Re: Problem with search

Post by Kofod95 »

Phoenix 1.0.8.16 running on Xampp, windows php 7.4.13:
"æ", "ø", "å" and "ü" are added to the URL correctly, but not finding products with those characters

//Daniel
I'm not smart, but sometimes even a blind chicken can find a corn.
Here are a lot of corns: Phoenix user guide
Piernas
Posts: 77
Joined: Thu Mar 11, 2021 2:16 am
Has thanked: 2 times
Been thanked: 5 times

Re: Problem with search

Post by Piernas »

Kofod95 wrote: Fri Aug 05, 2022 5:10 pm "æ", "ø", "å" and "ü" are added to the URL correctly, but not finding products with those characters
With corrupting characters I meant internally - it's the variable that holds the query what is getting the weird symbols.
User avatar
Kofod95
VIP Member
VIP Member
Posts: 326
Joined: Sat Feb 06, 2021 7:38 pm
Has thanked: 50 times
Been thanked: 82 times

Re: Problem with search

Post by Kofod95 »

Sorry, I must have been tired when responding previously.. I'll check correctly next time I'm on the PC.

//Daniel
I'm not smart, but sometimes even a blind chicken can find a corn.
Here are a lot of corns: Phoenix user guide
Piernas
Posts: 77
Joined: Thu Mar 11, 2021 2:16 am
Has thanked: 2 times
Been thanked: 5 times

Re: Problem with search

Post by Piernas »

Kofod95 wrote: Fri Aug 05, 2022 9:31 pm Sorry, I must have been tired when responding previously.. I'll check correctly next time I'm on the PC.

//Daniel
Don't worry I was just pointing that the characters are being correctly added to the URL but not internally. Thanks for confirming!
Post Reply