1.0.8.5 Questions / Comments / Concerns

Ask the community for help and support.
Nigel
VIP Member
VIP Member
Posts: 90
Joined: Mon Jan 11, 2021 1:39 am
Has thanked: 21 times
Been thanked: 5 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by Nigel »

Should the last file to be removed actually be "focusRequiredTab.php" and not focusRequired.php as this doesn't seem to exist.

Tags:
Nigel
VIP Member
VIP Member
Posts: 90
Joined: Mon Jan 11, 2021 1:39 am
Has thanked: 21 times
Been thanked: 5 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by Nigel »

All seems fine now after making those additional deletions.
The duplicate link has gone and it still works.
raiwa
PhoenixCart Developer
PhoenixCart Developer
Posts: 372
Joined: Sat Dec 21, 2019 8:08 am
Location: Sant Iscle de Vallalta, Barcelona, Spain
Has thanked: 22 times
Been thanked: 51 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by raiwa »

Updated 1.0.8.4 to 1.0.8.5:
I get the following error in Admin: Modules: Content:
Notice: Trying to access array offset on value of type null in
C:\xampp_7.4.11\htdocs\xxxxxxxxxxxxxxx\includes\system\versioned\1.0.8.1\country.php
on line
37
When the GDPR Link[account] module is installed. Uninstalled and reinstalled it, but the same error.
Public Phoenix Change Log Cheat Set on Google Sheets
https://docs.google.com/spreadsheets/d/ ... sp=sharing

Need Help?viewtopic.php?f=10&t=27
ecartz
Lead Developer
Lead Developer
Posts: 1234
Joined: Tue Nov 05, 2019 6:02 pm
Has thanked: 4 times
Been thanked: 128 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by ecartz »

raiwa wrote: Sun Aug 08, 2021 8:15 am Notice: Trying to access array offset on value of type null in
C:\xampp_7.4.11\htdocs\xxxxxxxxxxxxxxx\includes\system\versioned\1.0.8.1\country.php
on line
37
TY. https://github.com/CE-PhoenixCart/Phoen ... 03e9f87fd8
Xpajun
VIP Member
VIP Member
Posts: 32
Joined: Thu Mar 04, 2021 1:18 pm
Has thanked: 1 time
Been thanked: 5 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by Xpajun »

I'm having problems with the action_recorder Table - I get this error when I try installing it in the database:

Code: Select all

SQL query:

CREATE TABLE action_recorder (
  id int NOT NULL auto_increment,
  module varchar(255) NOT NULL,
  user_id int,
  user_name varchar(255),
  identifier varchar(255) NOT NULL,
  success char(1),
  date_added datetime NOT NULL,
  PRIMARY KEY (id),
  KEY idx_action_recorder_module_date (module, date_added),
  KEY idx_action_recorder_user_id (user_id)
) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci

MySQL said: Documentation
#1071 - Specified key was too long; max key length is 1000 bytes
Open new phpMyAdmin window
I'm using MariaDB 10.3.27-MariaDB
Current Store is now running 1.0.7.5 - php 7.3.24
About to work on 1.0.8.5 - php 7.3.24
Xpajun
VIP Member
VIP Member
Posts: 32
Joined: Thu Mar 04, 2021 1:18 pm
Has thanked: 1 time
Been thanked: 5 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by Xpajun »

Also the same problem with pages Table
Current Store is now running 1.0.7.5 - php 7.3.24
About to work on 1.0.8.5 - php 7.3.24
ecartz
Lead Developer
Lead Developer
Posts: 1234
Joined: Tue Nov 05, 2019 6:02 pm
Has thanked: 4 times
Been thanked: 128 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by ecartz »

Please set the tables to InnoDB. E.g.

Code: Select all

CREATE TABLE action_recorder (
  id int NOT NULL auto_increment,
  module varchar(255) NOT NULL,
  user_id int,
  user_name varchar(255),
  identifier varchar(255) NOT NULL,
  success char(1),
  date_added datetime NOT NULL,
  PRIMARY KEY (id),
  KEY idx_action_recorder_module_date (module, date_added),
  KEY idx_action_recorder_user_id (user_id)
) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci Engine InnoDB
Xpajun
VIP Member
VIP Member
Posts: 32
Joined: Thu Mar 04, 2021 1:18 pm
Has thanked: 1 time
Been thanked: 5 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by Xpajun »

ecartz wrote: Wed Sep 15, 2021 12:40 pm Please set the tables to InnoDB. E.g.

Code: Select all

CREATE TABLE action_recorder (
  id int NOT NULL auto_increment,
  module varchar(255) NOT NULL,
  user_id int,
  user_name varchar(255),
  identifier varchar(255) NOT NULL,
  success char(1),
  date_added datetime NOT NULL,
  PRIMARY KEY (id),
  KEY idx_action_recorder_module_date (module, date_added),
  KEY idx_action_recorder_user_id (user_id)
) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci Engine InnoDB
Thank you Matt - that worked - the only tables that were affected were action_recorder, configuration and pages.
This was from the phoenix.sql as included in Phoenix 1.0.8.5 - Having just looked at my tables i notice that the Engine is MyISAM on them all - the problem with using old databases I suppose
Current Store is now running 1.0.7.5 - php 7.3.24
About to work on 1.0.8.5 - php 7.3.24
LeeFoster
VIP Member
VIP Member
Posts: 56
Joined: Sun Feb 28, 2021 9:41 pm
Been thanked: 2 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by LeeFoster »

I must have done something wrong as I don't even have the categories/products option on my drop down.
LeeFoster
VIP Member
VIP Member
Posts: 56
Joined: Sun Feb 28, 2021 9:41 pm
Been thanked: 2 times

Re: 1.0.8.5 Questions / Comments / Concerns

Post by LeeFoster »

LeeFoster wrote: Wed Sep 22, 2021 11:24 pm I must have done something wrong as I don't even have the categories/products option on my drop down.
OK this was a me issue, caused by another addon and is fixed now.

However, I have lost all my tabs on the product admin page. Can anyone point me in the direction of getting them back?
Post Reply