IMPORTANT - Read Me Before Posting

Ask the community for help and support.
Locked
admin
Site Admin
Site Admin
Posts: 119
Joined: Wed Oct 30, 2019 1:34 pm
Has thanked: 19 times
Been thanked: 15 times

IMPORTANT - Read Me Before Posting

Post by admin »

Need Help?

You've come to the right place. This post offers some general suggestions on how to get the help you need, quickly and efficiently.

First check the Phoenix User Guide.

With over thousands of posts, your question has likely been asked and answered already so try searching first. Using Google search generally produces the best results. In the Google search bar, just enter CE Phoenix Cart and a description of the problem you are having or a likely topic for that problem and see what results are returned. You may get the help you need faster than you think.

If you can't find the answer you need using Google Search then perhaps someone on the forums can help. Help is provided by volunteers, so please be considerate of their time, and provide as much information as possible.

Here is a list of the information you are required to provide. Not all of it may be applicable to your particular situation, but providing as much detail as possible will result in a faster and more relevant reply.
  1. Which version of Phoenix you are using?
    • you can find this at Admin > Tools > Version Checker or Admin > Tools > Server Info
    • please provide the full version number, which is 4 digits ie 1.0.5.8
  2. Is this a new install or an existing store?
    • provide your URL if you are able to.
  3. What version of PHP are you using?
    • you can determine this by looking at Admin > Tools > Server Info
  4. What Addons have you installed
    • list all the addons
  5. What "customised changes" have you made to core code
    • any core code changes you have made, list them
Without ALL of the data above, you are asking us to guess what is wrong. Sometimes we can guess...but we should not need to. Remember that everyone here is a volunteer, so don't waste our time and don't waste your time.

Now you are ready to provide a detailed description of the problem you are having, including if applicable, the steps needed to reproduce it.

Provide a link to the page where the problem can be seen or if you are receiving an error message, a screen shot or the exact text of the message displayed is extremely helpful. You may only be able to see the error message in the logs. The more detailed information you can provide the better. Be sure to obscure (***-out) sensitive information such as your server account name.

Sometimes we may ask to see your "configure.php" files.

You have at least two of them;
  1. admin/includes/configure.php
    • this controls the admin side
  2. includes/configure.php
    • this controls the shop side
I guesstimate that a good 50% of reported problems are down to malformed configure.php file. If you need to show your configure.php file(s), remove or obscure the database name, user, and password!

Other potential issues to factor in;

Check Phoenix Cart PHP and Database (MariaDB or MySQL) requirements - https://github.com/CE-PhoenixCart/Phoen ... quirements
If your Host has recently updated the version of PHP they are using, it can cause a variety of problems. If you are experiencing issues with PHP 7 or later, more recent versions of Phoenix Cart may solve the problem. If you are using an older PHP or MariaDB or MySQL, you might want to use an older version of Phoenix Cart or better, get your host to update. Phoenix Cart handles all versions of PHP, MariaDB or MySQL which are currently supported with security fixes so any version that is older than Phoenix Cart supports is too old to be used safely.

Addons

Addons can be submitted, downloaded and support for them can be found in the Addons Library
Ask for support directly from the author where you downloaded the addon in the Addons Library (see the Addon Discussion/Support tab there) - DO NOT ask in this Community Help & Support Forum.
Addons are clearly flagged with the Phoenix Cart version for which they have been made.
Support for the Addon is usually only provided for that version.
Before installing an Addon, ensure it supports the Phoenix Cart version you have installed.
Before updating to a new Phoenix Cart version, first ensure any installed Addons have been updated to support that new version.

3rd party Problems

If your problem relates to a 3rd party product or anything acquired elsewhere, then you should go back to the author or vendor of that 3rd party product and ask for help there.

Certified Developers

If all else fails or you need help updating an older addon, creating a new one, getting core code changed to suit your needs, hosting, templates or anything else ... Certified Developers are available to help you. You can see the list of Certified Developers CE Phoenix Cart Developers - by using one of these great guys you are directly helping the Phoenix project, so get in touch with them, they don't bite.

Please note:
Post to ask for help or post to offer help, other post content may be deleted.
Referencing or linking to service providers not in this list may be deleted.
Periodically, inactive members are deleted.
Locked