Page 1 of 1

A question about PHP version

Posted: Tue Sep 29, 2026 12:06 pm
by cerberus
Hi,

I installed the shop not realising the webspace was set at PHP v8.1

I have tried to upgrade the PHP version to PHP v8.2, but the product page will not load when I do that.

I had video on the product page and I have removed that, I had a Back button and I have tuned that off, I had edited the image disclaimer box so I turned that off as well, but still the product page will not load beyond PHP version 8.1

Has anyone any ideas ?

Thank you
Steve

Re: A question about PHP version

Posted: Tue Sep 29, 2026 12:28 pm
by burt
Look in your hosting error_log. You will find the exact error...allowing better diagnosis as to what is causing it.

Re: A question about PHP version

Posted: Tue Sep 29, 2026 1:28 pm
by cerberus
In the control panel "Latest web server error logs" it says :

2026-09-29 14:19:41.027247 [INFO] [1293209] [T0] [APVH_jimswebs_Sualt-php81:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:18:03.208822 [INFO] [1272267] [T0] [APVH_jimswebs_Sualt-php82:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:12:39.362148 [INFO] [1272267] [T0] [APVH_jimswebs_Sualt-php81:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:12:21.460634 [INFO] [1272269] [T0] [APVH_jimswebs_Sualt-php81:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:01:56.322441 [INFO] [1271235] [T0] [APVH_jimswebs_Sualt-php81:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:01:17.994206 [INFO] [1236162] [T0] [APVH_jimswebs_Sualt-php82:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:01:15.346392 [INFO] [1236159] [T0] [APVH_jimswebs_Sualt-php82:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 14:01:00.619407 [INFO] [1236163] [T0] [APVH_jimswebs_Sualt-php82:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 13:58:48.689264 [INFO] [1236159] [T0] [APVH_jimswebs_Sualt-php81:] set restart marker to /home/jimswebs/.lsphp_restart.txt
2026-09-29 13:28:33.429710 [INFO] [1192523] [T0] [172.68.183.19:10100>2a06:98c0:3600::103#APVH_jimswebshop.com] File not found [/home/jimswebs/public_html/404.shtml]
2026-09-29 13:28:33.429630 [INFO] [1192523] [T0] [172.68.183.19:10100>2a06:98c0:3600::103#APVH_jimswebshop.com] File not found [/home/jimswebs/public_html/wp-admin/install.php]


So I dont think it say anything ?



In the shop error log its quite full, but the last error that keeps repeating is :

Stack trace:
#0 /home/jimswebs/public_html/shop/includes/system/versioned/1.0.8.4/template.php(79): ht_product_opengraph->execute()
#1 /home/jimswebs/public_html/shop/templates/default/includes/components/template_top.php(13): Template->build_blocks()
#2 /home/jimswebs/public_html/shop/templates/default/includes/pages/product_info.php(13): require('/home/jimswebs/...')
#3 /home/jimswebs/public_html/shop/product_info.php(23): require('/home/jimswebs/...')
#4 {main}
thrown in /home/jimswebs/public_html/shop/includes/modules/header_tags/ht_product_opengraph.php on line 30
[29-Sep-2026 09:18:12 America/New_York] PHP Warning: The [en_GB] locale will be treated as en in /home/jimswebs/public_html/shop/includes/system/versioned/1.0.9.3/intl_date_formatter.php on line 144
[29-Sep-2026 09:18:12 America/New_York] PHP Warning: The [en_GB] locale will be treated as en in /home/jimswebs/public_html/shop/includes/system/versioned/1.0.9.3/intl_date_formatter.php on line 144
[29-Sep-2026 09:18:12 America/New_York] PHP Warning: The [en_GB] locale will be treated as en in /home/jimswebs/public_html/shop/includes/system/versioned/1.0.9.3/intl_date_formatter.php on line 144
[29-Sep-2026 09:18:12 America/New_York] PHP Fatal error: Uncaught Error: Call to undefined function mb_substr() in /home/jimswebs/public_html/shop/includes/modules/header_tags/ht_product_opengraph.php:30


Sorry to say it means nothing to me, am I going to have to start again ?
or will it matter if I just keep running on PHP v8.1 ?

Re: A question about PHP version

Posted: Tue Sep 29, 2026 1:34 pm
by burt
[29-Sep-2026 09:18:12 America/New_York] PHP Fatal error: Uncaught Error: Call to undefined function mb_substr() in /home/jimswebs/public_html/shop/includes/modules/header_tags/ht_product_opengraph.php:30

This means mbstring is not enabled in your php8.2.

If this is cPanel

Go to: cPanel > MultiPHP > PHP Extensions

Select the PHP 8.2 version and make sure:

mbstring

is enabled.

In other words, most likely your hosting is "at fault" for this.

Re: A question about PHP version

Posted: Tue Sep 29, 2026 2:01 pm
by cerberus
In cPanel > MultiPHP I do not have mbstring (I have been trying to set the php to 8.2 in MultiPHP)

But in cPanel PHP Selector (that is also set to PHP 8.1 as standard, there is a mbstring and it is turned on), will it be ok to try turning up the PHP version here to 8.2 or above ?

(I am never too sure if I can turn them back to what they were, I know I can on the multiPHP, but I dont know about on the PHP Selector)

Sorry about all the questions

Re: A question about PHP version

Posted: Tue Sep 29, 2026 2:08 pm
by burt
These are questions for your host, as all hosts are set up differently and each knows their own system inside out (or at least they should do).

Re: A question about PHP version

Posted: Tue Sep 29, 2026 2:22 pm
by cerberus
ok thank you. I will send them a message to see what they say.

Re: A question about PHP version

Posted: Tue Sep 29, 2026 3:25 pm
by cerberus
They got back to me and said it was ok to turn up the PHP on the PHP Selector page.

It turns out I had to set the PHP version on the PHP Selector page (which has mbstring) first, then I can set the PHP version in MultiPHP

(setting it in MultiPHP will not work on its own, it has to be set on the PHP Selector page first)

So now running PHP8.4 and the product page shows :)

Thank you burt for all your advice and help.

You have no idea how many times the colour has drained from my face when I make mistakes and the site/page will not load, I literally feel it go :) and that is not including the mini heart attacks :) I cant say its turning my hair grey as that happened many years ago :)

This is a stressful hobby, but interesting and fun at the same time :)

I need a cup of tea now.

Re: A question about PHP version

Posted: Tue Sep 29, 2026 7:20 pm
by azpro
You have no idea how many times the colour has drained from my face when I make mistakes and the site/page will not load, I literally feel it go :) and that is not including the mini heart attacks :) I cant say its turning my hair grey as that happened many years ago :)
Yes - we do! We have all been there feeling panicked - silliy etc.... if we can help - we will! And it is a learning curve for you and everyone - this is not only about Phoenix but also how to work with the different tools like FTP - debugging - browser console - server error logs - etc. etc. But it is also/equally important when your site goes live/into production to be able to asses problems. You will need these skills sooner or later anyway! It takes time for everyone to feel confident - but you are right - eventually it is fun!

Success and hang in there!

Regards! A